[Dovecot] dovecot and libnss-ldap

Nicolas Boullis nicolas.boullis at ecp.fr
Tue Feb 13 09:57:49 UTC 2007

Hi Timo,

Timo Sirainen wrote:
> On Mon, 2007-02-12 at 16:19 +0100, Nicolas Boullis wrote:
>>Is the problem with libnss-ldap a recent problem (I mean it was not a
>>problem with older dovecot such as my 0.99.14)? Is it still a problem
>>even with 1.0rc22? Is there any hope to have it fixed before 1.0?
> No. The problem has always existed, and it can't be solved in Dovecot
> without completely redesigning dovecot-auth's PAM support. I probably
> will do that after 1.0 though.
> Anyway the RedHat people figured out the bug a week ago. See
> https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=154314

That's really good news.
But if I understand it correctly (not sure at all I do), the real
problem lies in libnss-ldap, and your changes in dovecot would work
around this bug. Is this correct?

Moreover, I tried tu use the reproducer from
http://people.redhat.com/tjanouse/dovecot/154314/ldaptest.c on one of my
Debian systems and (after I created the corresponing accounts in my LDAP
directory) all I got was dots... Would it mean that for some reason
Debian's libnss-ldap is safo to use with dovecot?

Thanks for writing dovecot, and for your continuing work to make it the
best POP/IMAP server ever.


More information about the dovecot mailing list