[Dovecot] dovecot and libnss-ldap

Nicolas Boullis nicolas.boullis at ecp.fr
Thu Feb 15 11:30:24 UTC 2007

Timo Sirainen wrote:
> On Tue, 2007-02-13 at 10:57 +0100, Nicolas Boullis wrote:
>>Moreover, I tried tu use the reproducer from
>>http://people.redhat.com/tjanouse/dovecot/154314/ldaptest.c on one of
>>Debian systems and (after I created the corresponing accounts in my
>>directory) all I got was dots... Would it mean that for some reason
>>Debian's libnss-ldap is safo to use with dovecot?
> I guess that's possible. There was something in the thread about linking
> with/without pthread support that changed something. Or did you not link
> the tester with pthreads?

I did compile with the exact command found in the comments of the file.
On debian systems, I only got dots. I also tried on a RedHat systems and
got a few exclamation marks, and a freeze after a few seconds...

I read that part about libnss_ldap being linked with/without pthread,
but I did not really understand.

Anyway, looking at some build logs, I see:
cc  -g -Wall -O2 -fPIC -Wall -fPIC   -o nss_ldap.so -shared
-Wl,-Bdynamic -Wl,--version-script,./exports.linux ldap-nss.o ldap-pwd.o
ldap-grp.o ldap-netgrp.o ldap-rpc.o ldap-hosts.o ldap-network.o
ldap-proto.o ldap-spwd.o ldap-alias.o ldap-service.o ldap-schema.o
ldap-ethers.o ldap-bp.o ldap-automount.o util.o ltf.o snprintf.o
resolve.o dnsconfig.o irs-nss.o pagectrl.o ldap-sldap.o  -lldap_r -llber
-lgssapi_krb5 -ldl -lnsl -lresolv -lpthread

Hence, it looks like Debian's libnss_ldap is linked with pthread. But
does this mean I am safe, even without the new "blocking=yes" option?


More information about the dovecot mailing list