[Dovecot] Dovecot on Solaris x86?

Tim Skirvin tskirvin at ks.uiuc.edu
Wed Feb 21 15:59:13 UTC 2007

        I'm trying to get dovecot working on Solaris x86.  I've got it
working just fine on RH Desktop 4; and while I have a built, limping
version on solx86, it's not actually usable except from other solx86

        Basic details:

        Version         1.0rc23
        OS              Solaris x86 (64 bit)
        CPU             Opteron
        Filesystem      NFS (but it's not getting that far)

        The general problem is apparently SSL-related.  I can connect
properly from another Solaris x86 machine, using either mutt or straight
openssl; but when I try mutt from a Solaris or Linux machine, I get the
error "SSL failed: I/O error" and it fails, and when I use openssl from a
Linux machine, I get something like this:

victor ~> stelnet xxxxxxxx.ks.uiuc.edu 993
+ openssl s_client -connect xxxxxxxx.ks.uiuc.edu:993 -verify -debug
verify depth is 0
depth=0 /C=US/ST=Illinois/L=Urbana/O=UIUC/OU=[...]
verify error:num=18:self signed certificate
verify return:1
depth=0 /C=US/ST=Illinois/L=Urbana/O=UIUC/OU=[...]
verify return:1
24748:error:140790E5:SSL routines:SSL23_WRITE:ssl handshake failure:s23_lib.c:226:

        Annoyingly, the same command run from a Solaris machine connects,
even though mutt doesn't.  (I'm using 'mutt -f imaps://xxxx/', which I
know works elsewhere; and the Linux mutt is the system default one, so I
don't suspect that it is the source of the problem.)

        The logs have been remarkably un-useful:

dovecot: Feb 21 09:41:21 Info: imap-login: Disconnected: rip=[...], lip=[...] TLS handshake

        The software was built in all cases with:

         ./configure --prefix=/usr/local/encap/dovecot-1.0rc23.1

        I've tried with both Sun's native cc and gcc compilers.  I have
also tried building on SPARC Solaris with the native cc compiler, to the
same (negative) effect.  (I used to have v0.99.14 running just fine on
this SPARC machine, so this worries me... but I only checked it just now
as an after-thought.)

        Any suggestions?

                            - Tim Skirvin (tskirvin at ks.uiuc.edu)
   Theoretical and Computational    http://www.ks.uiuc.edu/~tskirvin/
Biophysics, Beckman Institute, UIUC    Senior Systems Administrator
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 185 bytes
Desc: not available
Url : http://dovecot.org/pipermail/dovecot/attachments/20070221/43b8b0b6/attachment.pgp 

More information about the dovecot mailing list