[Dovecot] Dovecot on Solaris x86?

Tim Skirvin tskirvin at ks.uiuc.edu
Fri Feb 23 21:05:36 UTC 2007

Bart Smaalders <barts at smaalders.net> writes:

>>        I've tried with both Sun's native cc and gcc compilers.  I have
>> also tried building on SPARC Solaris with the native cc compiler, to the
>> same (negative) effect.  (I used to have v0.99.14 running just fine on
>> this SPARC machine, so this worries me... but I only checked it just now
>> as an after-thought.)

> Here's a link: http://wiki.dovecot.org/CompilingSource

        I presume you meant 'ssl_cipher_list' instead of 'ss_cipher_list'.
Still, it doesn't work for me, and I'm getting error messages like this:

dovecot: Feb 23 15:00:03 Warning: imap-login: SSL_accept() failed: error:1408F119:SSL routines:SSL3_GET_RECORD:decryption failed or bad record mac [xxx.xxx.xxx.xxx]

        At least a different error message on the client end, though: "SSL
failed: unspecified protocol error".

        Again, I built with this:

CPPFLAGS=-I/usr/local/ssl/include LDFLAGS='-L/usr/local/ssl/lib -R/usr/local/ssl/lib' ./configure --with-ssl=openssl --prefix=/usr/local/encap/dovecot-1.0.rc23_1

        Any more suggestions?  Or do you have some binaries I could try?

                            - Tim Skirvin (tskirvin at ks.uiuc.edu)
   Theoretical and Computational    http://www.ks.uiuc.edu/~tskirvin/
Biophysics, Beckman Institute, UIUC    Senior Systems Administrator
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 185 bytes
Desc: not available
Url : http://dovecot.org/pipermail/dovecot/attachments/20070223/0507a6f5/attachment.pgp 

More information about the dovecot mailing list