[Dovecot] Dovecot and horde issues

John H. Bennett III bennettj at johnbennettservices.com
Wed May 2 06:45:14 EEST 2007

Quoting Francisco Reyes <lists at stringsutils.com>:

> John H. Bennett III writes:
>> I am having difficulties trying to get the current stable version   
>> of  horde's imp webmail to work correctly using dovecot 1.0rc15.  I  
>>  am  using a pre-release version of SME Server 8 which runs on top   
>> of  CentOS 5.  I have also tried using the 1.0 release of dovecot   
>> as well.
> We have very simmilar problems to what you describe in pre 1.0 releases.
>> What is happenning is that when I login to imp, I don't see any    
>> folders.  I can create folders in imp which do get created in my    
>> Maildir directory, but I can't see them.  If I revert back to    
>> dovecot-0.99.14-1.2, then I am able to see my folders.
> This this:
> namespace private {
>  separator = .
>  prefix = INBOX.
>  inbox = yes
> } Or some other simmilar setup in namespace.
> That namespace setting we used for Courier compatibility so you may
> need to have it slightly different. However do check the namespace AND
> make sure to try this in the 1.0 Release.
> We had on/off issues with some users until RC29.. Then upgraded to 1.0
> when it was a week old and so far we are very happy with Dovecot.
> Going to start migrating all our Courier servers to it.

Thanks for responding, but still no go.  My updated dovecot.conf looks  
like this:

dovecot -n
# /etc/dovecot.conf
login_dir: /var/run/dovecot/login
login_executable(default): /usr/libexec/dovecot/imap-login
login_executable(imap): /usr/libexec/dovecot/imap-login
login_executable(pop3): /usr/libexec/dovecot/pop3-login
mail_location: maildir:~/Maildir
mail_debug: yes
mail_executable(default): /usr/libexec/dovecot/imap
mail_executable(imap): /usr/libexec/dovecot/imap
mail_executable(pop3): /usr/libexec/dovecot/pop3
mail_plugin_dir(default): /usr/lib/dovecot/imap
mail_plugin_dir(imap): /usr/lib/dovecot/imap
mail_plugin_dir(pop3): /usr/lib/dovecot/pop3
   type: private
   separator: .
   location: maildir:~/Maildir
   inbox: yes
   hidden: yes
auth default:
     driver: pam
     args: *
     driver: passwd
     args: blocking=yes

If I run through the testinstallation -    
http://wiki.dovecot.org/TestInstallation, everything looks good.
telnet localhost 143
Connected to localhost.
Escape character is '^]'.
* OK imapfront ready. + stunnel
1 login user1 user1
1 OK Logged in.
2 select inbox
* FLAGS (\Answered \Flagged \Deleted \Seen \Draft)
* OK [PERMANENTFLAGS (\Answered \Flagged \Deleted \Seen \Draft \*)]  
Flags permitted.
* OK [UNSEEN 1] First unseen.
* OK [UIDVALIDITY 1177716836] UIDs valid
* OK [UIDNEXT 2] Predicted next UID
2 OK [READ-WRITE] Select completed.
2 list "" *
* LIST (\HasNoChildren) "." "Drafts"
* LIST (\HasNoChildren) "." "Trash"
* LIST (\HasNoChildren) "." "Mine"
* LIST (\HasNoChildren) "." "junkmail"
* LIST (\HasNoChildren) "." "testing"
* LIST (\HasNoChildren) "." "INBOX"
* LIST (\HasNoChildren) "." "This is a test"
* LIST (\HasNoChildren) "." "dfagjladfa"
2 OK List completed.
3 logout
* BYE Logging out
3 OK Logout completed.
Connection closed by foreign host.

What else can I check?

Thanks again,


More information about the dovecot mailing list