[Dovecot] Quota warning not generated

Doug Council dcouncil at nethere.com
Fri May 25 20:14:28 EEST 2007

I am testing out the unofficial quota warning patch with Dovecot 1.0.0, 
and no matter what values I use for the storage or messages values, the 
warning script is never executed.

My plugin settings are:

plugin {
   quota = maildir:storage=20480
   quota_warning = storage=80%:messages=10 /usr/local/bin/quota-warning.sh

I've tried the following quota_warning lines without any luck:

quota_warning = storage=80% /usr/local/bin/quota-warning.sh
quota_warning = messages=10 /usr/local/bin/quota-warning.sh
quota_warning = storage=80%:messages=10 /usr/local/bin/quota-warning.sh

The quota-warning.sh script is set to 0755 and currently just syslogs a 
warning using logger(1).  Run independently of Dovecot, it works fine.

Here is a sample maildirsize file (if that is at all important) from when 
I tried the messages=10 setting:

335322 12
14016 1
58058 1
46529 1
37623 1
55252 1
61901 1
53422 1
56228 1

There are more than 10 messages in the mailbox, but the quota-warning.sh 
script never gets executed.  When using storage=80%, the maildirsize file 
has the correct values (not included in this message), but it never 
executes the script as well.

Does anyone have any ideas?


More information about the dovecot mailing list