[Dovecot] no maildirsize file being created -dovecot v1.1

Barry R Cisna brcisna at eazylivin.net
Sat Jun 21 01:26:26 EEST 2008

Hello List,

Getting ready to setup a new dovecot sendmail squirrelmail server for
our school which is currently running on a 4 year old install of the
same, which has worked like a champ by the way.
dovecot-1.1 rc10 rpm
Problem: I can not get my dovecot 1.1 rc10(rpm) to generate an
maildirsize file in each of the users homedir. I have re-edited the
dovecot.conf file many many times but still no joy.
If I uninstall and install the default dovecot 1.0.1x rpm that ships
with EL5 i get the maildirsize file to generate correctly without a
hitch. I am wanting to use the  check_quota plugin for SM this time so I
need to get this functioning correctly.
How would I go about troubleshooting this. The only error I get in
maillog is when I log into SM I do see were dovecot tries to check for
the maildirsize file but it can not find it of course and then says "
skipping quota check",,so I think I have my dovecot.conf file setup
correctly. Dovecot is simply not generating the maildirsize file.
Following lines added to the end of dovecot.conf file:
protocol imap {
  mail_plugins = quota imap_quota
protocol pop3 {
  mail_plugins = quota
# In case you're using deliver:
protocol lda {
  mail_plugins = quota
plugin {
  quota = maildir
  quota_rule = *:storage=1GB
  # 10% of 1GB = 100MB
  quota_rule2 = Trash:storage=10%%
  # 20% of 1GB = 200MB
  quota_rule3 = Spam:storage=20%%

,,I have reversed the above to have quota=maildir,,etc 
above the protocol directives as well and still no joy.

Sidenote: I also tried dovecot v1.1 rc5 rpm as well with the same results.
Any tips from anyone would be appreciated.

Barry Cisna

More information about the dovecot mailing list