[Dovecot] Cygwin and dovecot-auth problems

Blacktate blacktate at yahoo.it
Sun Jun 22 01:47:08 EEST 2008

21/06/2008 16.51 - Timo Sirainen wrote:
> On Sat, 2008-06-21 at 16:44 +0200, Blacktate wrote:
>> Patch, make, replace the dovecot-auth executable, start inetd, 
>> telnet localhost: just the same error ("EOF while reading..."). The
>>  error log shows:
>> dovecot: Jun 21 15:51:53 Error: child 9904 (auth) returned error 53
> Wasn't this logged before? This is the real reason why it doesn't 
> work. Googling Cygwin 53 exit code shows that it means it can't find 
> some DLL. Maybe because Dovecot drops PATH environment before calling
>  dovecot-auth, or maybe Cygwin needs some other environment variable?
> One sure way to test that theory is the attached patch that doesn't 
> clear environment anywhere ever.

Yep! Almost there. At least, now the "53" error is gone.
After looking at another thread between you and Ronny (back to
November), I ran cygcheck:

| bash-3.2 > cygcheck.exe /usr/local/libexec/dovecot/dovecot-auth.exe

Fact is, the Cygwin "bin" directory (containing the first two DLLs) is
not in my Windows PATH. If I add it, now the error 53 disappears even
without your patch.

Sadly, I can't even login. This is what happens:

1) start inetd
2) in the mail client (Thunderbird), click on "Inbox"
     2a) dovecot's info log shows the "...starting up" message
     2b) imap-login process starts to eat cpu indefinitely
     2c) thunderbird's debug log says:

0[274ce8]: 4d48a58: clearing
17868[4d98cb0]: ImapThreadMainLoop entering [this=4d48a58]
17868[4d98cb0]: 4d48a58: entering
  = currentUrl

     2d) ...and it stays there.

3) stop inetd

     3a) info log shows this (a bit late, isn't it?):

dovecot: Jun 22 00:25:53 Info: auth(default): passwd-file /etc/passwd:
Read 26 users

     3b) error log shows this (should be the debug message of the first 
patch you sent me):

dovecot: Jun 22 00:25:53 Error: auth(default): Info: starting dovecot-auth

     3c) imap-login dies
     3d) dovecot and dovecot-auth are still alive, but no connections 
can  be made on port 143

That's it, for now. I'll try to struggle a bit more, in case there's a 
fault on my part which I don't get right now.


More information about the dovecot mailing list