[Dovecot] Problem Compiling 1.1.1 on AIX

Jackie Hunt jackie at yuma.acns.colostate.edu
Wed Jun 25 00:35:02 EEST 2008

Hi all,

We've been running Dovecot since December '07 with with no glitches.
It's a great solid piece of software, thanks so much Timo!!

I thought I'd try out 1.1.1, so I brought it down and tried compiling
it on AIX, using the IBM compiler, xlc.  It's what I've used all along.
The error I'm seeing on the make is:

        source='array.c' object='array.o' libtool=no  DEPDIR=.deps depmode=aix /
bin/sh ../../depcomp  xlc -DHAVE_CONFIG_H -I. -I../..    -I/usr/local/openssl_0.
9.7e/include  -g -qcpluscmt  -c array.c
"macros.h", line 149.68: 1506-211 (S) Parameter list must be empty, or consist o
f one or more identifiers separated by commas.
make: 1254-004 The error code from the last command is 1.

Looking at macros.h, the section it is erroring on is:

#  define CONTEXT_CALLBACK(name, callback_type, callback, context, ...) \
        ({(void)(1 ? 0 : callback(context)); \
        name(__VA_ARGS__, (callback_type *)callback, context); })
#  define CONTEXT_CALLBACK(name, callback_type, callback, context, ...) \
        name(__VA_ARGS__, (callback_type *)callback, context)

The second define is the line the error occurs on.  Has anyone seen this
before.  I'm assuming xlc can't handle the '...' parameter, and an hoping
there is an option I can enable.  Just thought I might see if anyone else
has already solved this issue.

Thanks much!
Jackie Hunt                                                       
Colorado State University
Fort Collins, CO  80523 

More information about the dovecot mailing list