[Dovecot] Problem Compiling 1.1.1 on AIX

Jackie Hunt jackie at yuma.acns.colostate.edu
Fri Jun 27 03:15:59 EEST 2008

> Can you somehow enable C99 support for xlc? Is there something like a
> -c99 parameter?

Thank Timo, Woosan and Asheesh for your help.  I did see a parameter for
xlc (-qlanglvl=extc99), but our compiler is too old, and it doesn't recognize
it.  I then tried gcc, we had version 4.0.0 installed, and it does compile.
I did have to do the changes Woonsan recommended (below).  

> In my case, I succeeded in making it after modification of two 
> generated sources:
> (1) src/plugins/quota/rquota.h
>     I added `#include <rpc/rpc.h>' on the top.
> (2) src/plugins/quota/rquota_xdr.c
>     I modified it like the following:
>       #include "/usr/include/rpcsvc/rquota.h"
>       ==>
>       #include "rquota.h"

My compiliation method wasn't very elegant.  I did the make, saw an error, 
and rquota.h was created.  I edited rquota.h as shown above.  I ran make 
a second time which errored, but generated rquota_xdr.c.  I edited 
rquota_xdr.c, and the third make succeeded.  Is there a cleaner method 
to use?

Thanks again, it's very comforting to know I can compile it!

Jackie Hunt                                                       
Colorado State University       
Fort Collins, CO  80523        

More information about the dovecot mailing list