[Dovecot] deliver fails - passdb doesn't support lookups?

Kyle Wheeler kyle-dovecot at memoryhole.net
Wed Mar 12 20:03:38 EET 2008


I'm trying to get `deliver` (the LDA) to function properly. I can get 
it to work without doing a user lookup, but for my own sense of 
sanity, I want to know what I'm doing wrong getting user lookups 
working. (I'm using dovecot 1.0.10).

Here's what I have in the "auth default" section:

     auth default {
         mechanisms = plain login
         passdb ldap {
             args= /var/lib/dovecot/dovecot-ldap.conf
         userdb static {
             args = uid=3728 gid=3728 home=/domains/%Ld/%Ln
         user = vpopmail
         socket listen {
             master {
                 path = /var/run/dovecot/auth-master
                 mode = 0600
                 user = vpopmail
                 group = vchkpw
             client {
                 path = /var/run/dovecot/auth-client
                 mode = 0660

And yet, when I run deliver, I get no warnings, no errors, and most 
especially, no email delivered. Here's how I call deliver:

     cat testemail | setuidgid vpopmail \
         /usr/local/libexec/dovecot/deliver \
         -d testuser at example.com

I tried running deliver within strace, and here's what I found. It 
opens up the authentication socket and writes:

     VERSION\t1\t0\nUSER\t1\ttestuser at example.com\tservice=deliver\n

And it gets back:


If I understand the authentication protocol correctly, that means an 
internal error occurred.

The dovecot log file reports this:

     Error: auth(default): static(testuser at example.com): passdb doesn't
     support lookups, can't verify user's existence

passdb? I thought it was the userdb that was important! What's going 
on here?

Men, as an organization, are getting more women than any other group 
working anywhere in the world. Wherever women are, we have men looking 
into it.
                                                      -- Jerry Seinfeld
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 204 bytes
Desc: not available
Url : http://dovecot.org/pipermail/dovecot/attachments/20080312/981fde5b/attachment.bin 

More information about the dovecot mailing list