[Dovecot] mbox file too large error with deliver

Gokdeniz Karadag gokdeniz at ceng.metu.edu.tr
Mon Nov 24 19:13:08 EET 2008

> Timo Sirainen <tss at iki.fi> wrote:
>> > Setting mailbox_size_limit to 0 made deliveries possible. a limit of  
>> > 2000000000 (<2GB) also did not show the errors. Thank you ! :)
>> >
>> > My issue is fixed but deliver might have a bug, so I will explain  
>> > things, sorry for not being clear previously.
>> >
>> > Old mail server was 32 bit(an old version of debian) and used  
>> > procmail for deliveries, that setup worked with the given limit of  
>> > 5GB and mailbox sizes above 1GB.
>> >
>> > After migrating to an 64 bit server (debian etch) and dovecot's  
>> > deliver, the stated delivery errors appeared for mailboxes above 1  
>> > GB. As I stated at the beginning of my reply, setting  
>> > mailbox_size_limit below 2GB made deliveries possible. I tried with  
>> > edge values, mailbox_size_limit=2147483648 (exactly 2GB) would give  
>> > the following error in postfix logs:
>> >
>> > fatal: main.cf configuration error: mailbox_size_limit is smaller  
>> > than message_size_limit
>> >
>> > A limit of 2147483648 - 1 worked fine.
>> >
>> > There are two distinct bugs probably, one in postfix and one in  
>> > dovecot.
> Postfix clearly is using signed 32bit integer here, which could be  
> considered a bug. But why do you think there's a bug in Dovecot? Note  
> that Dovecot never even sees this value. It's the kernel that enforces  
> it, Dovecot simply reacts to a write() failure.

The logs stating the "File too large" errors belong to dovecot's deliver
process. While I was searching for a solution, I read that deliver honors
mailbox_size_limit setting of postfix, I'm not sure if that is correct or not.

Note that the destination mailboxes are smaller than 2GB here, but still gets
"File too large" error. The machine is 64-bit, so no fs related kernel limits
on file size.

I have not dived into postfix and/or dovecot internals, but my guess is ,
dovecot gets the mailbox size limit and behaves accordingly. If that is the
case, the problem can be fixed in dovecot's deliver code.

If postfix sets file size limit with ulimit before execing deliver, OR uses a
similar process which is out of deliver's control, then there is nothing
concerning dovecot. If someone can clarify the issue I would be happy.

Gokdeniz Karadag

More information about the dovecot mailing list