[Dovecot] v2.0.rc3 released

Odhiambo Washington odhiambo at gmail.com
Wed Jul 21 17:08:43 EEST 2010

On Wed, Jul 21, 2010 at 2:22 PM, Timo Sirainen <tss at iki.fi> wrote:

> On 21.7.2010, at 7.38, Odhiambo Washington wrote:
> > I've tried compiling this one on FreeBSD-8. I was running RC2 which had
> > compiled successfully.
> Yeah, FreeBSD compiling is broken in rc3. Fixed it:
> http://hg.dovecot.org/dovecot-2.0/rev/4fb7e5327efc

Thanks. That fixed it. However, out of curiosity, what does the warning
below mean?

s -Wpointer-arith -Wchar-subscripts -Wformat=2 -Wbad-function-cast
-Wstrict-aliasing=2 -MT imap-zlib-plugin.lo -MD -MP -MF
.Tpo -c imap-zlib-plugin.c -o imap-zlib-plugin.o >/dev/null 2>&1
mv -f .deps/imap-zlib-plugin.Tpo .deps/imap-zlib-plugin.Plo
/bin/sh ../../../libtool --tag=CC    --mode=link gcc   -std=gnu99 -g -O2
-Wall -W -Wmissing-prototypes -Wmissing-declarations -Wpointer-arith -Wc
har-subscripts -Wformat=2 -Wbad-function-cast -Wstrict-aliasing=2 -module
-avoid-version   -o lib30_imap_zlib_plugin.la -rpath /opt/dovecot2/lib/
dovecot imap-zlib-plugin.lo ../zlib/lib20_zlib_plugin.la -lrt

*** Warning: Linking the shared library lib30_imap_zlib_plugin.la against
the loadable module
*** lib20_zlib_plugin.so is not portable!
libtool: link: gcc -shared  .libs/imap-zlib-plugin.o   -Wl,-rpath
libs -Wl,-rpath -Wl,/opt/dovecot2/lib/dovecot
../zlib/.libs/lib20_zlib_plugin.so -lrt    -Wl,-soname
-Wl,lib30_imap_zlib_plugin.so -o .libs/lib30
libtool: link: ar cru .libs/lib30_imap_zlib_plugin.a  imap-zlib-plugin.o
libtool: link: ranlib .libs/lib30_imap_zlib_plugin.a
libtool: link: ( cd ".libs" && rm -f "lib30_imap_zlib_plugin.la" && ln -s
"../lib30_imap_zlib_plugin.la" "lib30_imap_zlib_plugin.la" )
Making all in doc
Making all in man

Best regards,
_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _
"If you have nothing good to say about someone, just shut up!."
               -- Lucky Dube

More information about the dovecot mailing list