[Dovecot] configure: error: unrecognized option: --docdir=/usr/share/doc/dovecot-2.0.11

Bruce Cheng itlist at gmail.com
Wed Apr 6 08:09:41 EEST 2011


Thank you for your soon reply.
I tried to build RPMS from source rpm file, due to I don't need to use
some API such llike postgresql, sqlite and so on.

I tried to upgrade automake and autoconf, but they all are new enough.

# yum install automake  autoconf
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * addons: centos.tt.co.kr
 * base: mirror.yongbok.net
 * extras: mirror.yongbok.net
 * rpmforge: fr2.rpmfind.net
 * updates: mirror.yongbok.net
Setting up Install Process
Package automake-1.9.6-2.3.el5.noarch already installed and latest version
Package autoconf-2.59-12.noarch already installed and latest version
Nothing to do

Please advise me how to fix this issue and thank you in advance.

2011/4/5 Timo Sirainen <tss at iki.fi>
> On Tue, 2011-04-05 at 16:11 +0800, Bruce Cheng wrote:
> > Hi,
> >
> > I tried to use ATrpms
> > (http://dl.atrpms.net/all/dovecot-2.0.11-1_126.src.rpm) to rebuild the
> > rpms. It is shown the error message as following:
> > configure: error: unrecognized option: --docdir=/usr/share/doc/dovecot-2.0.11
> > Try `./configure --help' for more information.
> >
> > I checked `./configure --help', it did contain the '--docdir' option.
> > I don't know how to fix it.
> I guess your autoconf/automake is too old. Although I don't know why the
> rpm builder wants to regenerate configure.

Best Regards,

More information about the dovecot mailing list