[Dovecot] Having trouble getting Dovecot to read a ~/Maildir configuration

Murray Collingwood murray at focus-computing.com.au
Thu Apr 21 03:12:40 EEST 2011

Hi folks

Setting up a new server, hence a few software packages have been upgraded /
changed.  On my old server (only 2 years old)  I was using Dovecot and
RoundCube (web mail app) and had a good experience so was keen to use these
again.  The only major change is I have switched from sendmail to exim4
(which was installed by default on this Debian server).  Exim4 appears to be
doing the right thing, however read on and see if you can spot the error.

I've tried two email clients, RoundCube (via apache) as a local connection
and Evolution as a remote connection.  Both appear to login to the Dovecot
IMAP connection okay (log entries included further down), although they
don't see any email.  The INBOX is completely empty.  Although when I check
out /home/postmaster/Maildir/new it has many messages waiting to be read.

It's like Exim4 is delivering the email into the ~/Maildir folder but
Dovecot is not seeing it....

I've tried these three combinations in dovecot.conf but they give the
same result:
#mail_location = maildir:~/Maildir   (ie this one I commented the line out
to see if Dovecot would work it out automatically)
mail_location = maildir:~/Maildir     (I think this one should work)
mail_location = maildir:~/Maildir:LAYOUT=fs   (Now I'm just desperate and
will try anything)

The dovecot log gives no indication of any errors:

This is the version I am running - it was the default version for Debian
installed via apt-get:
2011-04-21 08:55:22 dovecot: Info: Dovecot v1.2.15 starting up (core dumps

This connection is using Evolution email client on Linux:
2011-04-21 08:40:05 imap-login: Info: Login: user=<postmaster>,
method=PLAIN, rip=, lip=

This connection is using roundcube via apache on the same server:
2011-04-21 08:40:41 imap-login: Info: Login: user=<postmaster>,
method=PLAIN, rip=, lip=, secured
2011-04-21 08:40:41 IMAP(postmaster): Info: Disconnected: Logged out

And finally a look at the ~/Maildir content for my "postmaster" user:
root at ds5683:/etc/dovecot# ls -al /home/postmaster/Maildir
total 148
drwx------ 6 postmaster postmaster  4096 Apr 21 08:55 .
drwxr-xr-x 3 postmaster postmaster  4096 Apr 19 08:12 ..
drwx------ 2 postmaster postmaster 12288 Apr 21 08:40 cur
-rw------- 1 postmaster postmaster 89088 Apr 21 08:40 dovecot.index.cache
-rw------- 1 postmaster postmaster  2376 Apr 21 08:40 dovecot.index.log
-rw------- 1 postmaster postmaster  5208 Apr 21 08:40 dovecot-uidlist
-rw------- 1 postmaster postmaster     8 Apr 21 08:55 dovecot-uidvalidity
-rw------- 1 postmaster postmaster     0 Apr 21 08:34
drwx------ 5 postmaster postmaster  4096 Apr 21 08:56 INBOX
drwx------ 2 postmaster postmaster 12288 Apr 21 09:39 new
drwx------ 2 postmaster postmaster  4096 Apr 21 09:39 tmp

So, can somebody help me get Dovecot to recognise the messages in this
mailbox please?
You can suggest anything you like.... upgrades, conf changes, low level
formating of HDD... at this stage I'm ready to try anything!


Murray Collingwood
Focus Computing
p +61 415 24 26 24

More information about the dovecot mailing list