[Dovecot] Panic when attempting index with Apache Solr : fts_solr plugin

A Dovecot User dovecot at digitalforplay.com
Tue Dec 13 01:49:22 EET 2011

Over the weekend I updated the OS on the machine in question to Fedora
15, which should have updated libcurl in the process, and I'm still
getting the same error message. I also moved Solr to another server
instead of trying to use it on the local box, but that didn't seem to
make a difference.

On 12/07/2011 11:22 PM, Timo Sirainen wrote:
> On Fri, 2011-12-02 at 12:47 -0600, A Dovecot User wrote:
>> [root at mymailserver ~]# doveadm -D index -u username mailbox inbox
> The "mailbox" isn't necessary above.
>> doveadm(username): Info: INBOX: Caching mails seq=1..466
>> doveadm(username): Panic: file solr-connection.c: line 545
>> (solr_connection_post_more): assertion failed: (maxfd >= 0)
> This happens every time? It can't index any mails at all? Have you tried
> with Dovecot v2.0?
> I can't reproduce it. Anyway I guess either I'm using libcurl wrong
> somehow, or there's a bug in libcurl..

More information about the dovecot mailing list