[Dovecot] expire-tool stops on first box with nothing to expire in it

Robert Schetterer robert at schetterer.org
Sun Jul 15 09:14:49 EEST 2012

Am 15.07.2012 05:34, schrieb Michael Wessel:
> Hi,
> I'm running dovecot 1.2.11 on Centos and have the expire plugin enabled.
> I've had this in place for some time but until now never actually ran
> the expire-tool. I'm now trying to put this to use.
> The expire plugin as such is working fine and also the tool is working
> fine - up to a point.
> When I run it with --test it goes through a bunch of boxes and lists the
> messages it would expunge and the new date being logged at the end. As
> soon as it hits the first box that has nothing in it that's expired
> however, it stops and goes no further. As an example here are the last
> two lines of the output when I just ran it:
> Info: user at domain.com/Trash: timestamp 1342320464 (Sat Jul 14 19:47:44
> 2012) -> 1342937319 (Sat Jul 21 23:08:39 2012)
> Info: nextuser at domain.com/Trash: stop, expire time in future: Sat Jul 14
> 20:41:49 2012
> If I run it again after the indicated expire time it will now also go
> through the nextuser at domain.com but then again stop as soon as it
> encounters another user with nothing to expire.
> As far as I can tell the same happens when I actually run the tool.
> Harder to tell of course as there is no output, but I can tell that not
> all boxes are expunged as they should be.
> Any ideas why this would be? Any way to get debug logging on this?
> Michael

1.2.11 is outdated you should upgrade 2.1.8 and try again

however 1.2.17 is latest patch level for 1.2

Best Regards
MfG Robert Schetterer

More information about the dovecot mailing list