[Dovecot] Issues with Plus addressing and detail part of subaddress.

Sean Kamath kamath at moltingpenguin.com
Sun Jul 15 11:50:23 EEST 2012

Hi all,

So, it's been a while.  I'm just ramping back up with Dovecot after a hiatus of a few years.

I've been using it fine, complete with Sieve, for about a year, with little or no issues.

I finally got around to setting up a second account, to start figuring out how I want to do some plus address filtering.

In a nutshell, I want to put mail for foo+bar in foo's 'bar' folder.  That's in the wiki.

I did this:

require ["fileinto", "envelope", "subaddress"];

if header :contains "subject" ["test"] {
 fileinto "Test";

if envelope :detail "to" "test" {
  fileinto "test";

So, this fails miserably.  No error message, nothing in the logs, no nothing.  Yet, when I run

sieve-test .dovecot.sieve /path/to/testmessage

it works just fine.  I even run

sieve-test -e .dovecot.sieve /path/to/testmessage

and it files it just fine into the folder.

I tried adding some debug logging, but it looks like vnd.dovecot.debug isn't in my version.

I searched the archives, and found a bit about adding (explicitly) the delimiter to the plugin section of 90-sieve.conf.  So I did that.

I'm running 2.0.13 of dovecot, and pigeonhole 0.2.3 on Solaris 10.

Before I dive in and upgrade everything, am I missing something simple?  The "test" bit works just fine (and in another account as well), so I think something's just not seeing the detail in subaddressing when mail is delivered (even though it works just fine with sieve-test).


More information about the dovecot mailing list