[Dovecot] 2.1.7 altmove not working

Alex Crow acrow at integrafin.co.uk
Fri Jun 8 20:58:24 EEST 2012

On 08/06/12 12:13, Alex Crow wrote:
> Hi list,
> I've just set up a 2.1.7 server, and have migrated a couple of 
> accounts across from a 2.0.15 server, keeping the old configs. I have 
> a strange problem on the new box in that altmove just doesn't work. I 
> have my main storage under /home/email, indexes under /home/indexes 
> and ALT under /home/email_archive.
> When I run the altmove command, the following broken symlink is 
> created in /home/email/integrafin.co.uk/acrow:
> lrwxrwxrwx.  1 email email     54 Jun  8 10:46 dbox-alt-root -> 
> /home/email_archive/integrafin.co.uk/a/acrow/mailboxes
> But nothing is created in the archive other than the empty directory: 
> /home/email_archive/integrafin.co.uk/a/acrow.
> My mail_location is:
> mail_location = 
> mdbox:/home/email/%d/%n:INDEX=/home/indexes/%d/%1n/%n:ALT=/home/email_archive/%d/%1n/%n
> This worked perfectly on the older server. I have attached my doveconf 
> -a output.
> Any help much appreciated.
> Regards
> Alex

BTW I need to add that even with -v -D there were no complaints from 
dovecot altmove, and nothing untoward in /var/log/maillog. I also forgot 
to specify that I'm running on Centos6.2, all updates applied, package 
was built with a combo of the spec file from ATRPMs and the latest 
source tarball.

I previously had the ATRPMS 2.1.1 package installed, same issue.

Please feel free to tell me if I'm doing something wrong (ie something 
has changed between 2.0 and 2.1 re ALT: storage.



More information about the dovecot mailing list