[Dovecot] 2.1.7 TLS issues

Christian Rößner c at roessner-network-solutions.com
Mon Jun 25 01:09:10 EEST 2012

>>>> I have an interesting problem: I am building dovecot packages for Ubuntu since 10.04. Never had bigger trouble with it. Now since 2.1.6 or 2.1.7 (I can not say more precisely), Thunderbird 10ESR and Outlook 2010 can no longer use 143/TLS correctly. Automx delvers 143/TLS and Outlook tells me that it can not create a secure connection. I changed automx to use 993/SSL and everything works. Under Thunderbird 10ESR, I get a box that tells me that I need to change settings. When I sent mail, TB told me that it could not copy the mail to the sent folder. I also changed to 993/SSL and everything is perfect.
>>>> At the other and, Apples Mail.app and iOS devices work perfectly over 143/TLS. So my guess is that it has to do with OpenSSL. Did something change in dovecot concerning TLS? Can I change options in the built process?
>>> What was the Dovecot version you were using previously which worked?
>> I am not sure which version worked. My best guess is 2.1.4 or 2.1.5, because I skipped 2.1.6. But 2.1.6 has the same issues, as my friend Uwe did report the same issues with that one.
>> @Robert: I am talking about Ubuntu 10.04, so this can not be a problem with openssl itself, as that did not change
> I've seen problems with all kinds of clients and servers, even with Dovecot 1.x where TLS/Auto settings fail and I simply always instruct end users to explicitly choose 993/SSL to get a good TLS connection reliably.
> It seems like it might not be so version-specific or even anything wrong at the server end.

I never had such problems before. When I was coding automx, all tests succeeded with Dovecot and Outlook 2007/2010 and also Thunderbird was working perfectly. So in my opinion this is a version specific problem, as it started somewhere in 2.1.4+. I am using Dovecot since 1.0 (something like this) and never had 143/TLS problems

Best regards
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 4873 bytes
Desc: not available
URL: <http://dovecot.org/pipermail/dovecot/attachments/20120625/5bf59da9/attachment-0004.bin>

More information about the dovecot mailing list