[Dovecot] started with dovecot sieve

mailinglist mailinglist at august.de
Wed Jun 27 11:38:57 EEST 2012

Am 2012-06-26 22:10, schrieb Daniel Parthey:
> Rolf wrote:
>> Am 2012-06-25 23:59, schrieb Daniel Parthey:
>> >Hi Rolf,
>> >
>> >Rolf wrote:
>> >>Jun 25 20:22:54 rolf14 dovecot: lda(rolf): Error: 
>> setegid(privileged) failed: Operation not permitted
> Doesn't lda(rolf) mean it is being executed under user "rolf",
> not root or dovecot?
could be. However, following your mail I tried several alternatives for 
grouping, made the user itself part of mail group, made postfix and 
dovecot part of the users real group, made all part of roots real group, 
made the users part of postfix and dovecot real group ... I could have 
made failures in trying all this combinations but the failure remained 
in any case. (I switched all back for security reasons, the failure is 
still there.)
> How exactly do you invoke lda from your /etc/postfix/master.cf?
these are my lines from /etc/postfix/main.cf:
#mailbox_command = procmail -a "$EXTENSION"
mailbox_command = /usr/lib/dovecot/deliver

if I switch procmail back on the input gets delivered and I can see 
them using roundcube as a client for dovecot.

> You might also try to use LMTP via TCP to deliver mails
> from postfix to dovecot to work around any permission problems.

LMTP would be new to me and I fear just other hard-to-understand 
configuration topics.
What I did as a workaround is to have a last rule in each 
.dovecot.sieve: fileinto "rest". It works and this way the INBOX is no 
longer needed.

>> I have installed dovecot and docecot-sieve by Debians aptitude
> You don't seem to be the only one with these problems, see Debian 
> BTS:
> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=626130

Do not understand how they have solved the problem. Changing 0660 to 
0600 for the /var/mail/user mboxes (with user:mail for user:group) seems 
not to be a logical solution - have not tried that.

More information about the dovecot mailing list