[Dovecot] Permission error

Koenraad Lelong dovecot at ace-electronics.be
Mon Sep 23 10:33:06 EEST 2013

Op 16-09-13 11:48, Koenraad Lelong schreef:
> Hi,
> I just tried with chown nobody:nogroup auth-worker
> Now the error is gone.
> The question remains : what does create auth-worker ? The installer ?
> then I think ubuntu does it wrong.
> Any comments ?
> Regards,
> Koenraad.


I'm sorry for the late reply but I'm not working full time on this 

Unfortunately, I now experienced and remembered the fact that the /run 
or /var/run directories are temporary directories, i.e. they are 
recreated on boot. Which means that the ownership is recreated on boot 
and in this case set to dovecot:root. Which means dovecot can't access 
the "file".
I googled and found I needed a section :
service auth-worker {
   # Auth worker process is run as root by default, so that it can access
   # /etc/shadow. If this isn't necessary, the user should be changed to
   # $default_internal_user.
user = $default_internal_user
This does not work, also setting the user to dovecot gives the same result :
2013-09-23 09:28:08 auth: Fatal: net_connect_unix(auth-worker) in 
directory /run/dovecot failed: Permission denied (euid=65534(nobody) 
egid=65534(nogroup) missing +r perm: /run/dovecot/auth-worker, dir owned 
by 0:0 mode=0755)
2013-09-23 09:28:08 master: Error: service(auth): command startup 
failed, throttling

I'm stuck, can anyone please point me into the right direction ?


Koenraad Lelong

More information about the dovecot mailing list