Corrupted index cache after migrating from maildir to mdbox

Karl O. Pinc kop at
Fri Oct 31 11:58:18 UTC 2014

I was poking around in the code and I think there's
only 1 last_indexed_uid in the data structure.  
I have no clue if this value is used outside of fts
but you could poke it with a stick and
try the doveadm fts rescan command to reset this to 0.

(Sorry if you tried this already.  I recently signed up
on the list.)

I'm seeing last_indexed_uid set to the wrong value (v2.2.9,
Subject: Bug in fts (solr?, Maildir?) incorrect last_indexed_uid)
in some cases.  Your error feels like the same kind of thing.

On 10/31/2014 05:47:51 AM, Tim wrote:
> Hey guys,
> I'm still getting theses errors while fetching mails via imap:
> Error: read(/home/vmail/.../mdbox/storage/m.7): FETCH BODY[] for
> mailbox
> INBOX UID 1823 got too little data: 284572 vs 47173
> Error: Corrupted index cache file
> /home/vmail/.../mdbox/mailboxes/INBOX/dbox-Mails/dovecot.index.cache:
> Broken virtual size for mail UID 1823
> I tried to export them with doveadm fetch. this works fine and doesnt
> create any errors at all at the loge file. Any further toughts here?
> Timo maybe?
> On 13.10.2014 10:20, Tim wrote:
> > all mails are stored on an xfs filesystem and only the local 
> dovecot
> > accesses it. Possible to fix the index.cache files? I havn't found
> > anything suitable in the docs. The doveadm-index commands are only
> for
> > the fts plugin I think.
> >
> >
> > On 13.10.2014 02:37, Daniel Parthey wrote:
> >> Maybe the index is corrupted too and the index.cache is a cached
> version of the corrupted index?
> >>
> >> Are you using NFS with mdbox and accessing one nfs mailbox
> directory concurrently from several dovecot hosts?
> >>

Karl <kop at>
Free Software:  "You don't pay back, you pay forward."
                 -- Robert A. Heinlein

More information about the dovecot mailing list