Sieve extprograms ?not exexuting?

E.B. emailbuilder88 at
Mon Jun 1 19:38:00 UTC 2015

> Hello, I was testing the extprograms plugin. I think I had it working
> in the past, but many things have changed since then, so no use
> trying to figure out where it broke - starting over again...
> Debug-enabled log give me:
> Apr 27 04:11:36 mail dovecot: lmtp(test at Debug:
> qOGyA0DePHVaOyHEM/SpMA: sieve: action execute: running
> program:
> Apr 27 04:11:36 mail dovecot: lmtp(test at Debug:
> waiting for program `/usr/local/etc/dovecot/sieve_globals/'
> to finish after 0 seconds
> So I guess it thinks it is running my script? But simple test script
> does nothing. Here it is:
> #!/bin/sh
> read INPUT
> INPUT="Hello world: $INPUT"
> echo "$INPUT" >> /tmp/hello
> echo "---------------------------" >> /tmp/hello
> Permissions on this script file for now are rwxrwxrwx
> But nothing goes to /tmp/hello at all. Script works when I run it
> manually. I also tried without the "read" but I think that's required
> isn't it? Anyway, what else can I do to debug this?

Turns out this is a problem with systemd. I have PrivateTmp=true
in the dovecot.service file so anything written to /tmp goes to lala
land (is it anywhere I can see outside of the dovecot process?).

Problem solved.

More information about the dovecot mailing list