[Dovecot] 1.0.rc13 released

Gábor Lénárt lgb at lgb.hu
Thu Nov 9 16:09:28 UTC 2006

Hello again,

Now found more and more strange messages, like:

pop3-login: Can't connect to auth server at default: Resource temporarily unavailable

auth(default): LDAP: ldap_result() failed: Can't contact LDAP server

auth(default): ldap(user,xxx.xxx.xxx.xxx): ldap_bind() failed: Server is unwilling to perform

And the most bizarre stuff:

auth(default): ldap_bind((null)) failed: Can't contact LDAP server

As far as I know this "(null)" is printed by eg printf() family of C library
calls and likes when %s is used and a NULL pointer is passed ...

My problem that dovecot pop3 daemon dies after a while (after some hours):
when reach that point, POP3 login no longer works, after issuing POP3
command "PASS", it just hangs. Stopping and restarting dovecot cures it for
some hours at least. The strange that these error log messages are produced
all the time, but not always cause the hang of the WHOLE service.

If someone have ANY information, please help me. We used tpop3d before, and
that also had similar problems (eg hanging the whole service after a while).
That LDAP server is OpenLDAP from Ubuntu 6.06 LTS on AMD64 (2.2.26-5ubuntu2.1).
You may think that if both of tpop3d and dovecot fails similary it should
be the problem of the LDAP server, however other services (web interface,
postfix) does work without a single problem since a month or so. Tried with
v2 and v3 LDAP protocol as well. I ran out of ideas ;-(

- Gábor

More information about the dovecot mailing list