[Dovecot] 1.0.rc13 released

Timo Sirainen tss at iki.fi
Sun Nov 12 13:02:00 UTC 2006

On Thu, 2006-11-09 at 17:09 +0100, Gábor Lénárt wrote:
> Hello again,
> Now found more and more strange messages, like:
> pop3-login: Can't connect to auth server at default: Resource temporarily unavailable

This means that dovecot-auth is busy and couldn't respond in time.

> auth(default): LDAP: ldap_result() failed: Can't contact LDAP server
> auth(default): ldap(user,xxx.xxx.xxx.xxx): ldap_bind() failed: Server is unwilling to perform

Well, this sounds like it really is down.

> And the most bizarre stuff:
> auth(default): ldap_bind((null)) failed: Can't contact LDAP server

This is strange. I tried to figure out a reason why it could happen, but
couldn't.. I added anyway an extra assert and changed one error string a
bit, so if this happens to you again in rc14 I could maybe debug it
further. Especially if it crashes, gdb backtrace would be helpful.

> My problem that dovecot pop3 daemon dies after a while (after some hours):
> when reach that point, POP3 login no longer works, after issuing POP3
> command "PASS", it just hangs. Stopping and restarting dovecot cures it for
> some hours at least. The strange that these error log messages are produced
> all the time, but not always cause the hang of the WHOLE service.

I guess the connection to LDAP server dies somehow. Does OpenLDAP have
some timeouts for connections? That might cause it I guess..

> If someone have ANY information, please help me. We used tpop3d before, and
> that also had similar problems (eg hanging the whole service after a while).
> That LDAP server is OpenLDAP from Ubuntu 6.06 LTS on AMD64 (2.2.26-5ubuntu2.1).
> You may think that if both of tpop3d and dovecot fails similary it should
> be the problem of the LDAP server, however other services (web interface,
> postfix) does work without a single problem since a month or so. Tried with
> v2 and v3 LDAP protocol as well. I ran out of ideas ;-(

I think the difference is that Dovecot keeps the connection open all the
time, while web/postfix keep reconnecting to it constantly.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
Url : http://dovecot.org/pipermail/dovecot/attachments/20061112/f10e99b6/attachment.pgp 

More information about the dovecot mailing list