[Dovecot] [Fwd: wrong dovecot GID while upgrading]

Zbigniew Szalbot zbyszek at szalbot.homedns.org
Sat Feb 17 21:58:43 UTC 2007

Sorry to have bothered - just read the updating file...!

I should have let the upgrading process remove the dovecot user...

Warm regards,


---------------------------- Original Message ----------------------------
Subject: wrong dovecot GID while upgrading
From:    "Zbigniew Szalbot" <zbyszek at szalbot.homedns.org>
Date:    Sat, February 17, 2007 21:10
To:      dovecot at dovecot.org


I tried to upgrade dovecot from 1.0.rc7 to rc22 but I got this error at
the end of the upgrade process:

Dovecot has reserved the groupname 'dovecot' and gid '143':
ERROR: groupname 'dovecot' already in use by gid '1003'
Please resolve these issues and try again:
Either remove the conflicting group or if you wish to continue using a
legacy gr
           oup override DOVECOT_GID.
*** Error code 1

Stop in /usr/ports/mail/dovecot.

So I went to /usr/ports/mail/dovecot and edited the Makefile to change the
GID into:

DOVECOT_UID?=   1003
DOVECOT_GID?=   1003

I saved the makefile and ran portupgrade again but I got stopped by
exactly the same error. I'd appreciate suggestions how to resolve this.

Thank you!

Zbigniew Szalbot

Zbigniew Szalbot

More information about the dovecot mailing list