[Dovecot] local rimapd not working with 1.1.1, fatal error

David Halik dhalik at jla.rutgers.edu
Tue Jun 24 22:47:05 EEST 2008

Hi all,

I just upgraded a couple of Fedora 9 workstations to try out 1.1.1 over 
NFS'd homedir's and I'm having trouble running dovecot in the same 
configuration we were with 1.0.14.

It's fairly simple, we use pine/alpine and set a couple of variables to 
fork rimapd directly:

* smtp-server=host (for the main mail machine)
* user-domain=host (same)
* set the inbox-path={localhost}INBOX
* ssh-command=%s %s %s %s
* ssh-path=/etc/rimapd

In rimapd we specifiy:

exec /usr/sbin/dovecot --exec-mail imap 2>/dev/null

In dovecot.conf we specify:

protocols = imap
listen = localhost
mail_location = 
namespace public {
        separator = .
        prefix = INBOX.
        inbox = yes
protocol imap {
mail_executable = /usr/libexec/dovecot/imap
mail_plugins = quota imap_quota

...and away we go. This enables us to run pine and dovecot locally on 
the workstations since our home directories are all NFS'd to a central 
server, essentially giving us Maildir access anywhere local.

This has been working great for a long time, and we still use it with 
1.0.14, but as soon as I upgraded to 1.1.1, pine is telling me:

"rsh to IMAP server timed out"
"localhost,143: Connection refused"

I know this is very pine specific, but our pine configuration hasn't 
changed, only dovecot has. I check the obvious answers like perms, and 
ensured the same dovecot conf exists, and it does. I'm pretty stumped. 
It's obviously the newer dovecot causing problems, but I don't know 
where exactly. If I run "/usr/sbin/dovecot --exec-mail imap" manually, i 
still get the normal IMAP session.

The only error I see anywhere is this in /var/log/maillog:

Jun 24 15:36:28 host IMAP(user): : Fatal: io_loop_handle_add: 
epoll_ctl(1, 2): Operation not permitted

That doesn't really tell me much though.

Any ideas? Is dovecot taking different arguments now so my rimapd line 
isn't working properly?

Any help would be appreciated.


David Halik
System Administrator
OIT-CSS Rutgers University
dhalik at jla.rutgers.edu

More information about the dovecot mailing list