[Dovecot] Upgrade Too 1.2.11 Broke Everything

Marcel Grandemange thavinci at thavinci.za.net
Thu Jul 1 19:57:11 EEST 2010

> I have had dovecot working successfully for years now, however after a
> system update , dovecot refused to start up complaing that im not using
> absolute paths.

> In regards to this file the following was changed to make it work...
> mail_location = mbox:~:INBOX=/var/mail/%u
> Used to be:
> mail_location = mbox:~/mail/:INBOX=/var/mail/%u

>>Here you don't change any relative path, but change to base dir of your 
>>mailboxes, that should be wrong for any user using the default path.

Not sure what you mean here.

> user_query = SELECT maildir, concat('/var/mail/',maildir) AS home, 125 AS
> uid, 125 AS gid FROM mailbox WHERE username = '%u' AND active = '1'
> This query used to be:
> user_query = SELECT maildir, maildir AS home, 125 AS uid, 125 AS gid FROM
> mailbox WHERE username = '%u' AND active = '1'

>>I guess, the problem is in maildir, this is not absolute.

> Jun 29 11:52:05 thavinci dovecot: IMAP(me at thavinci.za.net):
> stat(/var/mail/me at thavinci.za.net/.imap/INBOX) failed: Not a directory

>>Your mysql query returns /var/mail/<<maildir>> as home directory, where 
>>Dovecot puts files.


>>a) post the content of one SQL record and

pdktar at thavinci.za.net	$1$06ae4b60$W/.iorSE/8ODJmh8Om4cf1	Tarun
Peedikayil	pdktar at thavinci.za.net	0	thavinci.za.net	2008-05-21
20:52:04	2008-05-21 20:52:04	1

I will be deleting this account so don't worry about the fact I disclosed
details ;>

>>b) make sure every user has an unique, writeable home directory.
>>(Note this applies to all user, but system users usually have an unique 

This is where the fault lies, ive fiddled till I got it working but I never
had to specify a writable unique home directory in the past, it just worked.
I create users via postfixadmin and tried to specify /var/mail/%u/ as the
unique directory but of course it complains that dir doesn't exist then.
I would have expected it to create it, itself. That would solve that issue.

I have done all sorts of work arounds now to continue operating without it
by using /var/empty and all that , but now my squirrelmail doesn't work like
it should anymore.



>>- -- 
>>Steffen Kaiser
>>Version: GnuPG v1.4.6 (GNU/Linux)


More information about the dovecot mailing list