[Dovecot] imap core dumping on signal 10

Chris Hoogendyk hoogendyk at bio.umass.edu
Wed Jul 21 20:52:24 EEST 2010

Timo Sirainen wrote:
> On Wed, 2010-07-21 at 12:05 -0400, Chris Hoogendyk wrote:
>> #0  0x000aa19c in mail_index_map (index=0x489, type=0) at /usr/local/src/dovecot/dovecot-1.2.12/src/lib-index//mail-index-map.c:502
> ..
>> #1  0x000a5adc in mail_index_try_open (index=0x160820) at /usr/local/src/dovecot/dovecot-1.2.12/src/lib-index//mail-index.c:300
> There is still too much optimization.. There should have been at least 2
> functions between these two.
>> (gdb) p hdr
>> $1 = (const struct mail_index_header *) 0x0
>> (gdb) p *hdr
>> Cannot access memory at address 0x0
>> (gdb) p &map->hdr
>> No symbol "map" in current context.
>> (gdb) p *map->rec_map
>> No symbol "map" in current context.
> These also fail because of the optimization. Well, maybe just try it the
> other way:
> CFLAGS=-g ./configure
> make clean
> make
> That should at least get rid of the optimizations. But I'm not sure if
> it crashes anymore with that. If it doesn't, try 
> CFLAGS='-g -O' ./configure

Well, bummer. ;-)

Once I got rid of the optimization (it still has -O) within that 
subdirectory of the source, I can't get it to fail. It seems to be just 

Part of the reason my first attempt back to you didn't work as expected 
was that I had CFLAGS in my build environment with -g -fast, which, on 
Sun, translates into a couple of different things, including, I believe, 
-O2. So, I had to get rid of -fast in my environment, and I also had to 
remove -fast from the Makefile down in src/lib-index. Once I had gone 
through steps 1-4 from your earlier email with those changes and 
restarted Dovecot, I poked at it from Squirrelmail for quite some time 
without any errors or failures. I did a search through my inbox, 
displayed 133 found emails, sorted them, read through a couple, deleted 
a bunch, wen back to the inbox, read a few more, paged forward, deleted 
a couple, etc.

So, . . .

I'm not sure what you want to make of that. It appeared when the error 
was happening, that the initial creation of ~chrisho/mail and the 
display of my inbox worked; but, after that, anything I tried to do 
failed with a crash and an error in squirrelmail. If I rm'd 
~chrisho/mail, I could get a fresh start. Maybe from all of that you can 
surmise something useful.

If anything else turns up, I'll let you know.

For now, I'm off to fix issues with mimedefang.

Maybe we'll be up and running and in service tomorrow.


Chris Hoogendyk

   O__  ---- Systems Administrator
  c/ /'_ --- Biology & Geology Departments
 (*) \(*) -- 140 Morrill Science Center
~~~~~~~~~~ - University of Massachusetts, Amherst 

<hoogendyk at bio.umass.edu>


Erdös 4

More information about the dovecot mailing list