[Dovecot] Dovecot 2.2.2: doveadm user doesn't honor -x option

Axel Luttgens AxelLuttgens at swing.be
Mon Jun 17 14:00:43 EEST 2013

Le 16 juin 2013 à 19:19, Timo Sirainen a écrit :

> [...]
> Fixed: http://hg.dovecot.org/dovecot-2.2/rev/c290383e60da

Hello Timo,

Thanks: just tried with 2.2.3, and it worked as expected.

>> The same config with Dovecot 2.1.16 yields expected results.
> v2.1 worked a bit differently by returning only the userdb info and skipping the dovecot.conf settings. Giving -u parameter to doveadm user uses the old way, and the service works also there.

Now that you wrote about that -u option, I vaguely recalled about it, and indeed found this one in the ChangeLog:

	doveadm user: Removed -m parameter and made it default. Added -u for
	old functionality.
	-u meaning "userdb lookup only".

>> [...]
>> Is there really an attempt to make use of the prefetch database?
> Yes.
>> If yes, under which circumstances could it succeed?
> Never with only a userdb lookup. But it's generic code. I guess the debug log entry could be hidden if it disturbs people too much..

Well... there's at least one guy who always gets trapped by such entries. ;-)

Best Regards,

More information about the dovecot mailing list