Failed running extprograms execute via socket - fatal recv(MSG_PEEK) failed disconnected

E.B. emailbuilder88 at
Tue May 5 18:39:27 UTC 2015

> >>>> Last two changes should fix this:
> >>>
> >>> Not yet -- this may be unrelated(?) but here is what I have
> >>> after installing the newest source package:
> >>>
> >>> Error: Couldn't load required plugin /usr/local/lib/dovecot/
> >>> dlopen() failed: /usr/local/lib/dovecot/ undefined symbol:
> >>> mail_deliver_ctx_get_log_var_expand_table
> >> Oh i guessing this requires the newest Dovecot source too (maybe you
> >> should put notice on the wiki that extprograms run-via-socket is broken until
> >> a new release?)
> >>
> >> After installed newest Dovecot and Sieve, I getting this:
> >>
> >> dovecot: lmtp(test at Debug: auth input:
> >> dovecot: lmtp(
> >> testl at Fatal: master: service(lmtp): child
> >> 7033 killed with signal 11 (core dumps disabled)
> >>
> >> With set mail_debug=yes doesn't give anything else of interesting for this.
> > Sorrys. I decided to "make clean" and do new "./configure" "make" and "make
> > install" for dovecot first, then pigeonhole to make sure nothing is off. After
> > I do that I get same original error:
> >
> > dovecot: script: Fatal: recv(MSG_PEEK) failed: disconnected
> >
> > I went to go verifying in dovecot-pigeonhole that the two new patches are there
> > by manual inspect the source files you patched. I found only the first one, not
> > maybe this
> > because I downloaded a snap shot link at the top that wasn't built with the
> > 2nd change?
> >
> > I put 2nd change in manually (its only one liner) rebuilded and after install.....
> > same error with recv(MSG_PEEK)
> Did you restart Dovecot?

Yes. One more restart now to make sure.

> Also, can you try running the script through `sieve-test -D -t -
> -Tlevel=matching` (see man page).

I cannot make this working. I'm logg in as unix user "adm" and
the sieve-test thinks that is the user it's delivering to?? I tried
to tell the recipient with both -a and -r and I put hard-coded -l
mail location but output still showing it wants to deliver to mailbox
for "adm" user. Also mail file has To: header with the correct
recipient but doesn't help. Users are virtual I cant logg in as the
correct recipient to run sieve-test. What do I do?

More information about the dovecot mailing list